summaryrefslogtreecommitdiff
path: root/android/build.gradle
diff options
context:
space:
mode:
Diffstat (limited to 'android/build.gradle')
-rw-r--r--android/build.gradle43
1 files changed, 43 insertions, 0 deletions
diff --git a/android/build.gradle b/android/build.gradle
new file mode 100644
index 0000000..2eb9c79
--- /dev/null
+++ b/android/build.gradle
@@ -0,0 +1,43 @@
+plugins {
+ id 'com.android.application' version '8.1.0'
+}
+
+android {
+ namespace 'fi.pulk.hacraft'
+ compileSdk 33
+
+ defaultConfig {
+ applicationId 'fi.pulk.hacraft'
+ versionCode 1
+ versionName '1.0'
+ minSdk 19
+ targetSdk 28
+
+ externalNativeBuild {
+ cmake {
+ arguments '-DSDL_ROOT=' + project.property('sdlRoot')
+ abiFilters 'arm64-v8a', 'x86_64'
+ }
+ }
+ }
+
+ externalNativeBuild {
+ cmake {
+ path 'jni/CMakeLists.txt'
+ }
+ }
+
+ sourceSets {
+ main {
+ java.srcDir project.property('sdlRoot') \
+ + '/android-project/app/src/main/java'
+ }
+ }
+
+ lintOptions {
+ // SDL's java shim has unaddressed linter warnings, and this is
+ // how they deal with them, apparently. *shrug*
+ // (Based on android-project/app/build.gradle, anyway.)
+ abortOnError false
+ }
+}